Disable Space Bar While Drawing

Wondering how to accomplish a certain animation task? Ask here.

Moderators: Fahim, Distinct Sun, Víctor Paredes, erey, Belgarath, slowtiger

User avatar
drumlug13
Posts: 489
Joined: Sun May 22, 2011 9:16 pm
Location: Beautiful St. Louis, MO

Disable Space Bar While Drawing

Post by drumlug13 » Thu Jun 20, 2019 2:47 pm

Is there a way to completely disable the space bar from starting the animation in the timeline? I know there is the option to toggle "Classic Points Editing" on & off, but both those options use the space bar to start the timeline. Also I don't see the space bar options in the edit shortcuts list. (Unless I missed it)

Has anybody personalized your shortcuts for a space bar friendly drawing mode? If we're going to spend a couple hours drawing, eliminating the space bar/play function, or even temporarily turning off the timeline off altogether would be great.
Or, is it possible to add a modifier to make the timeline play? I'm totally fine with permanently setting play at Shift + Space Bar in both Classic Points Editing and new mode if that's an option.

Moving the canvas and playing the timeline with the same shortcut has been a long-time frustration.

Or have I missed the really obvious solution here? That is my usual M.O.
User avatar
synthsin75
Posts: 7103
Joined: Mon Jan 14, 2008 11:20 pm
Location: Oklahoma
Contact:

Re: Disable Space Bar While Drawing

Post by synthsin75 » Fri Jun 21, 2019 4:28 am

I don't remember there being any way to change that behavior. Scripting *might* be able to do something to help. Let me think on it.
User avatar
drumlug13
Posts: 489
Joined: Sun May 22, 2011 9:16 pm
Location: Beautiful St. Louis, MO

Re: Disable Space Bar While Drawing

Post by drumlug13 » Fri Jun 21, 2019 1:36 pm

Much appreciated Wes
Tsongo
Posts: 38
Joined: Wed Jan 31, 2018 12:12 pm

Re: Disable Space Bar While Drawing

Post by Tsongo » Fri Jun 21, 2019 8:33 pm

Setting the number of frames to 1 ?
User avatar
drumlug13
Posts: 489
Joined: Sun May 22, 2011 9:16 pm
Location: Beautiful St. Louis, MO

Re: Disable Space Bar While Drawing

Post by drumlug13 » Fri Jun 21, 2019 9:21 pm

Tsongo wrote:
Fri Jun 21, 2019 8:33 pm
Setting the number of frames to 1 ?
I actually tried that but you still have the space bar moving you off of frame zero. Then you still have to go back, and re-select your drawing tool, because they disappeared on frame 1. You can enable drawing tools on frames other than 1, but then you're left with a bunch of orphaned keyframes bloating the timeline.

If we could set it to zero frames that would fix it.
User avatar
synthsin75
Posts: 7103
Joined: Mon Jan 14, 2008 11:20 pm
Location: Oklahoma
Contact:

Re: Disable Space Bar While Drawing

Post by synthsin75 » Fri Jun 21, 2019 11:52 pm

drumlug13 wrote:
Fri Jun 21, 2019 9:21 pm
If we could set it to zero frames that would fix it.
You can set both the start and end to zero in project settings. Then spacebar has no where to go.
User avatar
Greenlaw
Posts: 4386
Joined: Mon Jun 19, 2006 5:45 pm
Location: Los Angeles
Contact:

Re: Disable Space Bar While Drawing

Post by Greenlaw » Sat Jun 22, 2019 2:37 am

Oh, that's funny. I tried that just for kicks and Moho still goes into play mode, it just infinitely plays frame 0. That makes sense of course but I wonder if continuously playing frame 0 makes it use extra CPU.

Anyway, just FYI.
D.R. Greenlaw
Artist/Partner - Little Green Dog | Little Green Dog Channel on Vimeo | Greenlaw's Demo Reel 2017
Lead Digital Animator, Dreamworks Animation

Image
User avatar
Greenlaw
Posts: 4386
Joined: Mon Jun 19, 2006 5:45 pm
Location: Los Angeles
Contact:

Re: Disable Space Bar While Drawing

Post by Greenlaw » Sat Jun 22, 2019 2:45 am

FWIW, pressing spacebar for playback is actually fairly standard in most animation, compositing and video editing programs.

In Moho, I don't even bother with the pan (hand) tool. I just press the right-mouse to move the canvas. This works fine with mouse or stylus, and I find it more natural then pressing the spacebar for panning. (Especially so when working with a tablet.)
D.R. Greenlaw
Artist/Partner - Little Green Dog | Little Green Dog Channel on Vimeo | Greenlaw's Demo Reel 2017
Lead Digital Animator, Dreamworks Animation

Image
User avatar
drumlug13
Posts: 489
Joined: Sun May 22, 2011 9:16 pm
Location: Beautiful St. Louis, MO

Re: Disable Space Bar While Drawing

Post by drumlug13 » Sat Jun 22, 2019 3:30 pm

I tried setting it to zero frames too but it automatically adds 1 frame for me. I'm on a Windows machine.

And I totally agree Greenlaw, I wouldn't want to reassign the what the spacebar does for the animating part of the workflow. I'm talking about when you sit at the computer knowing that you are going to be spending the next hour or so using only the drawing tools. It would be nice to be able to toggle into a "drawing mode" that temporarily changes the behavior of the spacebar. Like the "Classic points editing keyboard shortcuts" option.

It happened a lot when I was drawing with a mouse, but now I'm drawing a lot more with a Wacom using the Freehand tool and I'm constantly bumping the play animation. I don't know what I'm doing different, but I guess you tell the spacebar what to do by how long you hold it down? Whatever it is, I guess using a tablet has me doing something different.

I guess now that you mention it I primarily used right click to move the canvas. It's probably best to just assign a right click to the pen.
Just between us.... I hate the button placement on the Wacom pen. But hey, at least they are super expensive :)
User avatar
drumlug13
Posts: 489
Joined: Sun May 22, 2011 9:16 pm
Location: Beautiful St. Louis, MO

Re: Disable Space Bar While Drawing

Post by drumlug13 » Sat Jun 22, 2019 4:26 pm

Just something to think about while we're in this rabbit hole...

I just noticed, (after using Moho since AS 7 :roll: ) that the spacebar does behave differently depending on which drawing tool you are using. A quick tap on the spacebar starts the animation timeline on every drawing tool except Transform Points and Add Points.

I know absolutely nothing about how Moho works on the scripting side of things, BUT I'm not going to let that stop me from guessing that it has something to do with how those 2 tools also use the spacebar to weld. So since the spacebar will start to play the animation when you're using the Freehand tool, that does explain why it's been happening so much more since using that tool and the tablet.

So there's probably a logical reason for not giving the Freehand tool the same spacebar behavior as Add Points & Transform Points... but just for the sake of discussion, why not? I can see how using spacebar to weld while using Freehand tool could be just as useful as the other 2 tools. Maybe even a little more precise than checking the Auto-weld box.


But on a side note... This post has reached the point that pretty much all of my posts do. Present a problem that was most likely never really a problem in the first place, and dwell on it for a long time.

In this case, now I know there's a difference between the two kinds of drawing tools, and I simply need to get used to holding the spacebar a fraction of a second longer, or assign a move canvas function to a pen button. So here I am 2 days and 4 posts later just to realize that Moho was fine from the start :? Time to make lunch :D
User avatar
Greenlaw
Posts: 4386
Joined: Mon Jun 19, 2006 5:45 pm
Location: Los Angeles
Contact:

Re: Disable Space Bar While Drawing

Post by Greenlaw » Sat Jun 22, 2019 5:18 pm

Sorry...I misunderstood. I thought the issue was that you were unintentionally pressing the spacebar and triggering play. Yes, tapping the spacebar makes it play but if you deliberately press and hold it, it behaves like the panning tool.

But for workspace navigation, I still think it's easier to just press and hold the right mouse button. You can also zoom with mouse using the mouse wheel. To rotate the canvas, you do need to press an extra key (Ctrl + Right Mouse) but still more convenient than switching tools. This works great with stylus too.
D.R. Greenlaw
Artist/Partner - Little Green Dog | Little Green Dog Channel on Vimeo | Greenlaw's Demo Reel 2017
Lead Digital Animator, Dreamworks Animation

Image
User avatar
synthsin75
Posts: 7103
Joined: Mon Jan 14, 2008 11:20 pm
Location: Oklahoma
Contact:

Re: Disable Space Bar While Drawing

Post by synthsin75 » Sat Jun 22, 2019 7:37 pm

drumlug13 wrote:
Sat Jun 22, 2019 3:30 pm
I tried setting it to zero frames too but it automatically adds 1 frame for me. I'm on a Windows machine.
I'm on Windows too. Do you have v12.5, build 22438?
A quick tap on the spacebar starts the animation timeline on every drawing tool except Transform Points and Add Points.
Those two use spacebar to weld points.
User avatar
drumlug13
Posts: 489
Joined: Sun May 22, 2011 9:16 pm
Location: Beautiful St. Louis, MO

Re: Disable Space Bar While Drawing

Post by drumlug13 » Sat Jun 22, 2019 8:04 pm

Yes I'm current with v12.5, build 22438

I have 2 comments up there since your last post Wes. I realized that spacebar won't play for the tools that weld. (10 years later)
It's the whole getting used to drawing with a tablet that has everything sideways
User avatar
Greenlaw
Posts: 4386
Joined: Mon Jun 19, 2006 5:45 pm
Location: Los Angeles
Contact:

Re: Disable Space Bar While Drawing

Post by Greenlaw » Sat Jun 22, 2019 11:00 pm

I think that's why I'm more comfortable using the right-mouse for panning. I mostly work with a stylus and tablet and I set the upper-finger switch to right-click. So, when I need to pan, I just moving my finger up slightly. For Zoom and Rotate, I still need to press a modifier key but that's what the tablet's Express Keys are for. When using a tablet, I hardly ever touch the keyboard when I'm using Moho, and using only the stylus and Express Keys quickly becomes second nature.

As a matter of fact, when I was using a Cintiq Companion for Moho, I enabled Moho's multi-touch feature so that, with the Stylus in my right hand and two-finger navigation with my left hand, I could scale, pan, and rotate entirely by touch. Very efficient. Sadly, the Companion's battery died last year and I hardly use it anymore. Nowadays, I use Moho with a regular Intuos Pro at home and a full size Cintiq at work.

Oh, I also have a secret weapon I call MQC that makes using Moho with a stylus and tablet even easier. Whoops! I guess the 'secret' is out. I'll make an official announcement about it and release it later this weekend.
D.R. Greenlaw
Artist/Partner - Little Green Dog | Little Green Dog Channel on Vimeo | Greenlaw's Demo Reel 2017
Lead Digital Animator, Dreamworks Animation

Image
User avatar
drumlug13
Posts: 489
Joined: Sun May 22, 2011 9:16 pm
Location: Beautiful St. Louis, MO

Re: Disable Space Bar While Drawing

Post by drumlug13 » Sat Jun 22, 2019 11:29 pm

Greenlaw wrote:
Sat Jun 22, 2019 11:00 pm
Oh, I also have a secret weapon I call MQC that makes using Moho with a stylus and tablet even easier. Whoops! I guess the 'secret' is out. I'll make an official announcement about it and release it later this weekend.
Oooh, I think I may be more excited to hear about that than #13

I've got a Cintiq 13HD and it's only got 4 express keys plus the Rocker Ring, so technically 9 buttons. I never could settle on which shortcuts to set them to. There are so many shortcuts in Moho I'm not sure I could ever use it without one hand on the keyboard but I can't wait to read what you've got.
Post Reply