Papagayo 1.2 problems

Discuss Papagayo issues here

Moderators: Fahim, Distinct Sun, Víctor Paredes, erey, Belgarath, slowtiger

macweenie
Posts: 25
Joined: Sun Dec 19, 2004 11:05 pm

Papagayo 1.2 problems

Post by macweenie » Tue Jul 18, 2006 1:30 am

I just downloaded the most current version (1.2) of Papagayo and installed it on a Mac OS X (10.4.7) system and it won't even open. I have rebooted, reinstalled, rebooted yet again and it still won't open. Is this a known issue or am I doing something wrong? The 1.1 version opened fine so I am hoping this is an issue with Papagayo? :shock: :shock:
User avatar
slowtiger
Posts: 5404
Joined: Thu Feb 16, 2006 6:53 pm
Location: Berlin, Germany
Contact:

Post by slowtiger » Tue Jul 18, 2006 10:23 am

There's a new version out? I didn't even know!
I'll test it later, fortunately I have both Mac OS 10.4.7 and 10.4.6 available.
User avatar
Lost Marble
Site Admin
Posts: 2190
Joined: Tue Aug 03, 2004 6:02 pm
Location: Scotts Valley, California, USA
Contact:

Post by Lost Marble » Tue Jul 18, 2006 8:01 pm

Intel or PPC?
ulrik
Posts: 1074
Joined: Thu Aug 11, 2005 10:32 pm
Location: Stockholm Sweden
Contact:

Post by ulrik » Tue Jul 18, 2006 11:04 pm

I have the same problem, it will not launch.
I'm on ppc os 10.4.7
User avatar
Lost Marble
Site Admin
Posts: 2190
Joined: Tue Aug 03, 2004 6:02 pm
Location: Scotts Valley, California, USA
Contact:

Post by Lost Marble » Wed Jul 19, 2006 12:19 am

Could one of you try something for me?

Run the Terminal app and type the following command and press enter:

python

You'll then get a new prompt that looks like this

>>>

At the new prompt this and press enter:

import wx

Please tell me what prints out in the terminal next (if anything).

Thanks.
ulrik
Posts: 1074
Joined: Thu Aug 11, 2005 10:32 pm
Location: Stockholm Sweden
Contact:

Post by ulrik » Wed Jul 19, 2006 12:54 am

Hi LM, I get nothing when writing import wx and hit enter, I only get a new prompt looking the same >>>
macweenie
Posts: 25
Joined: Sun Dec 19, 2004 11:05 pm

Post by macweenie » Wed Jul 19, 2006 7:34 am

Sorry, just got back to check the forum. I use a PPC Mac and in a second I will give you the terminal results...

Last login: Tue Jul 18 14:01:57 on console
Welcome to Darwin!
Virus:~ eric$ python
Python 2.3.5 (#1, Mar 20 2005, 20:38:20)
[GCC 3.3 20030304 (Apple Computer, Inc. build 1809)] on darwin
Type "help", "copyright", "credits" or "license" for more information.
>>> import wx
>>>

Hope it helps!

PS: The name of my machine is Virus (I don't HAVE a virus...) :D
User avatar
slowtiger
Posts: 5404
Joined: Thu Feb 16, 2006 6:53 pm
Location: Berlin, Germany
Contact:

Post by slowtiger » Wed Jul 19, 2006 10:55 am

Test results:

Papagayo 1.2 on G5 PPC Mac OS 10.4.7 with Python 2.3.5 doesn't start.

Papagayo 1.2 on G4 PPC Mac OS 10.4.6 with Python 2.2 doesn't start.
ulrik
Posts: 1074
Joined: Thu Aug 11, 2005 10:32 pm
Location: Stockholm Sweden
Contact:

Post by ulrik » Wed Jul 19, 2006 1:59 pm

I tried papagayo on my macbook intel to, but it will not launch, and in terminal writing "import wx" nothing happens
User avatar
Lost Marble
Site Admin
Posts: 2190
Joined: Tue Aug 03, 2004 6:02 pm
Location: Scotts Valley, California, USA
Contact:

Post by Lost Marble » Wed Jul 19, 2006 7:10 pm

Sorry to worry anyone, but seeing nothing happen after typing wx is a good thing - the bad news would be if you saw an error saying the wx module was not found.

Does anyone have Apple's developer tools installed? I'd like to hear from anyone who does or does not, and whether there's a correlation between Papagayo working or not working.
User avatar
Lost Marble
Site Admin
Posts: 2190
Joined: Tue Aug 03, 2004 6:02 pm
Location: Scotts Valley, California, USA
Contact:

Post by Lost Marble » Wed Jul 19, 2006 7:12 pm

In the meantime, here's a link to the previous version for OS X:

http://www.lostmarble.com/downloads/pap ... os_1.1.zip

This is too bad - the new version runs reall ynicely on an Intel Mac (that is, if it runs at all).
macweenie
Posts: 25
Joined: Sun Dec 19, 2004 11:05 pm

Post by macweenie » Wed Jul 19, 2006 9:37 pm

I have the dev tools installed, but have never really used them. Tell me what you need done (specifically) and I will do it...

Oh yeah, I also meant to mention that even though my previous post shows that I have Python 2.3.5, I had installed Python 2.4 several months ago so I could run blender (not that I CAN run blender but that's another issue). I don't know why the version shows as 2.3.5 but I can assure you I did install 2.4 because if I hadn't blender would not run, and it does.
User avatar
Lost Marble
Site Admin
Posts: 2190
Joined: Tue Aug 03, 2004 6:02 pm
Location: Scotts Valley, California, USA
Contact:

Post by Lost Marble » Wed Jul 19, 2006 10:39 pm

No, I don't need you to try anything with the dev tools - I was just wondering if some component was requiring them to be present, but that doesn't seem to be the issue.

Can you try this in Terminal?

pythonw /Applications/Papagayo/Papagayo.app/Contents/Resources/papagayo.py

Let's see if that spits out an error message.

Thanks.
macweenie
Posts: 25
Joined: Sun Dec 19, 2004 11:05 pm

Post by macweenie » Wed Jul 19, 2006 11:34 pm

I'm getting this:

Last login: Wed Jul 19 18:30:14 on ttyp1
Welcome to Darwin!
Virus:~ eric$ pythonw /applications/papagayo/papagayo.app/contents/resources/papagayo.py
/Library/Frameworks/Python.framework/Versions/2.4/Resources/Python.app/Contents/MacOS/Python: can't open file '/applications/papagayo/papagayo.app/contents/resources/papagayo.py': [Errno 2] No such file or directory
Virus:~ eric$

However, does capitalization count here? It usually doesn't on a Mac but this is Unix no?

PS: I re-installed version 1.1 earlier today, should I re-install 1.2 before I run the test?
Last edited by macweenie on Wed Jul 19, 2006 11:43 pm, edited 1 time in total.
ulrik
Posts: 1074
Joined: Thu Aug 11, 2005 10:32 pm
Location: Stockholm Sweden
Contact:

Post by ulrik » Wed Jul 19, 2006 11:42 pm

Lost Marble wrote:No, I don't need you to try anything with the dev tools - I was just wondering if some component was requiring them to be present, but that doesn't seem to be the issue.

Can you try this in Terminal?

pythonw /Applications/Papagayo/Papagayo.app/Contents/Resources/papagayo.py

Let's see if that spits out an error message.

Thanks.
I tried it and got this:
Ulrik-Bod-ns-dator-2:~ ulrikboden$ pythonw /Applications/Papagayo/Papagayo.app/Contents/Resources/papagayo.py
2006-07-20 00:39:49.108 Python[484] CFLog (21): Error loading /Library/QuickTime/Motion.component/Contents/MacOS/Motion: error code 4, error number 0 (Library not loaded: /Library/Frameworks/Motion.framework/Versions/A/Motion
Referenced from: /Library/QuickTime/Motion.component/Contents/MacOS/Motion
Reason: image not found)
2006-07-20 00:39:49.117 Python[484] CFLog (21): Error loading /Library/QuickTime/Motion.component/Contents/MacOS/Motion: error code 4, error number 0 (Library not loaded: /Library/Frameworks/Motion.framework/Versions/A/Motion
Referenced from: /Library/QuickTime/Motion.component/Contents/MacOS/Motion
Reason: image not found)
2006-07-20 00:39:49.124 Python[484] CFLog (21): Error loading /Library/QuickTime/Motion.component/Contents/MacOS/Motion: error code 4, error number 0 (Library not loaded: /Library/Frameworks/Motion.framework/Versions/A/Motion
Referenced from: /Library/QuickTime/Motion.component/Contents/MacOS/Motion
Reason: image not found)

and the "python" papagayo launched
Post Reply