Moho MP4 Export animation Error

Discuss Moho bugs (or suspected bugs) with other users. To report bugs to Smith Micro, please visit support.smithmicro.com

Moderators: Fahim, Distinct Sun, Víctor Paredes, erey, Belgarath, slowtiger

User avatar
JanR90
Posts: 100
Joined: Sun Oct 04, 2015 1:24 am
Location: Slovakia

Moho MP4 Export animation Error

Post by JanR90 » Sat May 26, 2018 3:50 pm

Hi guys, i have a problem with exporting animation in moho, if i choose a MP4 a error apears and it is imposible to export animation in mp4 format. It creates only a file that has 0 B and cant by opened :/

here a screenshot

Image


can it be because i use physics in my animation? When i start a new animation whitout physics it ia no problem to export to mp4 but i dont know why, when i use physic it is imposibvle to export as mp4 :/
YouTube Cartoon Jokes Channel: https://www.youtube.com/channel/UC2BQGB ... erPOIEXzAw
Youtube Personal Channel: https://www.youtube.com/channel/UCx_w74 ... 3jMryYMJeg
I want to thank everyone for liking, subscribing and support. You are awesome!
User avatar
Maestral
Posts: 327
Joined: Tue Jan 27, 2009 5:44 pm
Location: Belgrade, Serbia

Re: Moho MP4 Export animation Error

Post by Maestral » Sat May 26, 2018 4:12 pm

Sounds like a codec issue (& image link is not working also)

Try with a re/installation of codec`s (K-Lite should work) or drivers / depends on hw, system ...

^this was before you add those line in regards to physics, but can`t see how it would affect export either way
User avatar
JanR90
Posts: 100
Joined: Sun Oct 04, 2015 1:24 am
Location: Slovakia

Re: Moho MP4 Export animation Error

Post by JanR90 » Sat May 26, 2018 4:27 pm

Maestral wrote:Sounds like a codec issue (& image link is not working also)

Try with a re/installation of codec`s (K-Lite should work) or drivers / depends on hw, system ...

^this was before you add those line in regards to physics, but can`t see how it would affect export either way
Yes, i was thinking if the physic affect it, so i make a simple animation whitout it, then i add those lines after i discovered that MP4 works only whitout physics :) but i dont understand why i can not export it as MP4 :/ Avi works, but the error apear only when is MP4 as exporting format chosen.

And now i try to make simple physics only whit one object, and it works whit mp4.... Maybe it is because of the many shapes?

here is the exportet video(as avi it was exported):

YouTube Cartoon Jokes Channel: https://www.youtube.com/channel/UC2BQGB ... erPOIEXzAw
Youtube Personal Channel: https://www.youtube.com/channel/UCx_w74 ... 3jMryYMJeg
I want to thank everyone for liking, subscribing and support. You are awesome!
User avatar
synthsin75
Posts: 7127
Joined: Mon Jan 14, 2008 11:20 pm
Location: Oklahoma
Contact:

Re: Moho MP4 Export animation Error

Post by synthsin75 » Sat May 26, 2018 6:11 pm

You might try with multi-threaded rendering disabled.
User avatar
JanR90
Posts: 100
Joined: Sun Oct 04, 2015 1:24 am
Location: Slovakia

Re: Moho MP4 Export animation Error

Post by JanR90 » Sat May 26, 2018 9:16 pm

synthsin75 wrote:You might try with multi-threaded rendering disabled.
same :/ and i deleted the physic group, so there is no physics used and the effect is trhe same error :(
YouTube Cartoon Jokes Channel: https://www.youtube.com/channel/UC2BQGB ... erPOIEXzAw
Youtube Personal Channel: https://www.youtube.com/channel/UCx_w74 ... 3jMryYMJeg
I want to thank everyone for liking, subscribing and support. You are awesome!
User avatar
JanR90
Posts: 100
Joined: Sun Oct 04, 2015 1:24 am
Location: Slovakia

Re: Moho MP4 Export animation Error

Post by JanR90 » Sat May 26, 2018 9:24 pm

synthsin75 wrote:You might try with multi-threaded rendering disabled.
can it be that the physic group somehow broke the moho file? to make these physics effect in the video above i used break apart shpaes, in scripts>layer effects>RT:break apart shpaes, and i have many shapes in it so... can somebody try it? xD
YouTube Cartoon Jokes Channel: https://www.youtube.com/channel/UC2BQGB ... erPOIEXzAw
Youtube Personal Channel: https://www.youtube.com/channel/UCx_w74 ... 3jMryYMJeg
I want to thank everyone for liking, subscribing and support. You are awesome!
User avatar
synthsin75
Posts: 7127
Joined: Mon Jan 14, 2008 11:20 pm
Location: Oklahoma
Contact:

Re: Moho MP4 Export animation Error

Post by synthsin75 » Sat May 26, 2018 11:28 pm

If you want to share the file, I can try rending it to MP4.
User avatar
JanR90
Posts: 100
Joined: Sun Oct 04, 2015 1:24 am
Location: Slovakia

Re: Moho MP4 Export animation Error

Post by JanR90 » Sun May 27, 2018 1:11 am

synthsin75 wrote:If you want to share the file, I can try rending it to MP4.
okey, send my your email adress tru PM please and i send you the file, or give me a link where to upload it so u can download it :)... but you must understand that i have no problem convert the avi in some video editor to MP4,but iam very intrested if in other user MOHO will the export to MP4 work, maybe u can tell me where i make a mistake or where the problem is:)
YouTube Cartoon Jokes Channel: https://www.youtube.com/channel/UC2BQGB ... erPOIEXzAw
Youtube Personal Channel: https://www.youtube.com/channel/UCx_w74 ... 3jMryYMJeg
I want to thank everyone for liking, subscribing and support. You are awesome!
User avatar
synthsin75
Posts: 7127
Joined: Mon Jan 14, 2008 11:20 pm
Location: Oklahoma
Contact:

Re: Moho MP4 Export animation Error

Post by synthsin75 » Sun May 27, 2018 1:23 am

JanR90 wrote:
synthsin75 wrote:If you want to share the file, I can try rending it to MP4.
okey, send my your email adress tru PM please and i send you the file, or give me a link where to upload it so u can download it :)... but you must understand that i have no problem convert the avi in some video editor to MP4,but iam very intrested if in other user MOHO will the export to MP4 work, maybe u can tell me where i make a mistake or where the problem is:)
If you upload it to somewhere like FileDropper, MediaFire, or DropBox, you can PM me the link.
User avatar
JanR90
Posts: 100
Joined: Sun Oct 04, 2015 1:24 am
Location: Slovakia

Re: Moho MP4 Export animation Error

Post by JanR90 » Sun May 27, 2018 12:58 pm

synthsin75 wrote:
JanR90 wrote:
synthsin75 wrote:If you want to share the file, I can try rending it to MP4.
okey, send my your email adress tru PM please and i send you the file, or give me a link where to upload it so u can download it :)... but you must understand that i have no problem convert the avi in some video editor to MP4,but iam very intrested if in other user MOHO will the export to MP4 work, maybe u can tell me where i make a mistake or where the problem is:)
If you upload it to somewhere like FileDropper, MediaFire, or DropBox, you can PM me the link.

okey :)
YouTube Cartoon Jokes Channel: https://www.youtube.com/channel/UC2BQGB ... erPOIEXzAw
Youtube Personal Channel: https://www.youtube.com/channel/UCx_w74 ... 3jMryYMJeg
I want to thank everyone for liking, subscribing and support. You are awesome!
User avatar
synthsin75
Posts: 7127
Joined: Mon Jan 14, 2008 11:20 pm
Location: Oklahoma
Contact:

Re: Moho MP4 Export animation Error

Post by synthsin75 » Sun May 27, 2018 7:19 pm

MP4 rendered fine here. The only difference I can think of, off hand, is that I don't have the images used in that file. You might try deleting those and trying again.

Maybe you don't have enough RAM to hold the images in memory while processing physics.
User avatar
JanR90
Posts: 100
Joined: Sun Oct 04, 2015 1:24 am
Location: Slovakia

Re: Moho MP4 Export animation Error

Post by JanR90 » Mon May 28, 2018 2:42 pm

synthsin75 wrote:MP4 rendered fine here. The only difference I can think of, off hand, is that I don't have the images used in that file. You might try deleting those and trying again.

Maybe you don't have enough RAM to hold the images in memory while processing physics.
but now iam exporting another tottaly different file with no physics, just a 2D mesh and i have same error :/

an i have 8 GB ram so i think there is no problem with that :/

iam so sad about it :(
YouTube Cartoon Jokes Channel: https://www.youtube.com/channel/UC2BQGB ... erPOIEXzAw
Youtube Personal Channel: https://www.youtube.com/channel/UCx_w74 ... 3jMryYMJeg
I want to thank everyone for liking, subscribing and support. You are awesome!
User avatar
JanR90
Posts: 100
Joined: Sun Oct 04, 2015 1:24 am
Location: Slovakia

Re: Moho MP4 Export animation Error

Post by JanR90 » Mon May 28, 2018 3:13 pm

synthsin75 wrote:MP4 rendered fine here. The only difference I can think of, off hand, is that I don't have the images used in that file. You might try deleting those and trying again.

Maybe you don't have enough RAM to hold the images in memory while processing physics.

I find the bug!!!!! xD now iam totaly sure about it!!!! My project are in custom size in project setttings, i have a 1200x1200 size and when i change it to another, it magicaly works.... so there is a bug ! but i think it is very sad that i cant export in a MP4 sqare format, its ideal for facebook, so i mus now crop it in a video editor :/

try to make a simpe animation of cirle faling down, if u can export it with these seting as a mp4 ;)

Image
YouTube Cartoon Jokes Channel: https://www.youtube.com/channel/UC2BQGB ... erPOIEXzAw
Youtube Personal Channel: https://www.youtube.com/channel/UCx_w74 ... 3jMryYMJeg
I want to thank everyone for liking, subscribing and support. You are awesome!
User avatar
synthsin75
Posts: 7127
Joined: Mon Jan 14, 2008 11:20 pm
Location: Oklahoma
Contact:

Re: Moho MP4 Export animation Error

Post by synthsin75 » Mon May 28, 2018 5:39 pm

Yeah, those are the settings I exported your file at...with no problem. I have no idea why square dimensions would be a problem. Sorry I couldn't be more help.
User avatar
JanR90
Posts: 100
Joined: Sun Oct 04, 2015 1:24 am
Location: Slovakia

Re: Moho MP4 Export animation Error

Post by JanR90 » Mon May 28, 2018 6:52 pm

synthsin75 wrote:Yeah, those are the settings I exported your file at...with no problem. I have no idea why square dimensions would be a problem. Sorry I couldn't be more help.
its okey, and iam very thankfull that u try! many many thanks! :) but in my case is the settings there the cause, :/ i found on this forum same problem:

https://www.lostmarble.com/forum/viewto ... 13&t=30555

and

https://www.lostmarble.com/forum/viewto ... =2&t=26290
YouTube Cartoon Jokes Channel: https://www.youtube.com/channel/UC2BQGB ... erPOIEXzAw
Youtube Personal Channel: https://www.youtube.com/channel/UCx_w74 ... 3jMryYMJeg
I want to thank everyone for liking, subscribing and support. You are awesome!
Post Reply