Groups inside Mask-Groups displayed wrong(but render correct

Discuss Moho bugs (or suspected bugs) with other users. To report bugs to Smith Micro, please visit support.smithmicro.com

Moderators: Fahim, Distinct Sun, Víctor Paredes, erey, Belgarath, slowtiger

Post Reply
DrNibbert
Posts: 46
Joined: Tue Jun 19, 2018 7:48 am

Groups inside Mask-Groups displayed wrong(but render correct

Post by DrNibbert » Tue Oct 23, 2018 8:53 am

Hey everyone!

Whenever i use Groups (wheather its a Switch-, Masking- or just a normal Group) inside a Masking-Group, it gets displayed wrong in the viewport.
But when i render it out, it is displayed correkt, so i don't think its a mistake i made.

I uploaded an simple example-file, can you verify this bug?
https://www.dropbox.com/s/vftfqvljwjqny ... .moho?dl=0

Especially with more complex rigs this gets quite anoying.

Thanks for your feedback!

(Moho 12.5 on MacOS)
Showreel 2018 https://vimeo.com/254290989 - Moho 12.5.1, macOS 10.10, Adobe CS6
User avatar
Maestral
Posts: 325
Joined: Tue Jan 27, 2009 5:44 pm
Location: Belgrade, Serbia

Re: Groups inside Mask-Groups displayed wrong(but render cor

Post by Maestral » Tue Oct 23, 2018 1:59 pm

1. Do you have GPU acceleration* (un)checked?
2. Why is your mask above the masked layers?

* lower right corner, Display Quality
hayasidist
Posts: 2116
Joined: Wed Feb 16, 2011 8:12 pm
Location: Kent, England

Re: Groups inside Mask-Groups displayed wrong(but render cor

Post by hayasidist » Tue Oct 23, 2018 2:06 pm

that file works fine here -- display and render the same - win 10 12.5 (but I always have GPU off!!)

but there is a known issue with complex / nested masking where the situation is exactly as you describe. e.g. using masking to create a mask -- taking your example file -- make group 1 a "hide all" masked group with its layer 1 as add invisibly to mask; and animate the points in the rectangle to partially include the other shapes...
User avatar
chucky
Posts: 3914
Joined: Sun Jan 28, 2007 4:24 am
Location: Van Diemen's Land
Contact:

Re: Groups inside Mask-Groups displayed wrong(but render cor

Post by chucky » Tue Oct 23, 2018 2:45 pm

GPU is great for image-based files but masking anything but the most simple file fails horribly.
Don't count on the display for non-gpu display either ( at this point in time) it may be still different if complex.
Sequential offender.
my latest animations
User avatar
Greenlaw
Posts: 4360
Joined: Mon Jun 19, 2006 5:45 pm
Location: Los Angeles
Contact:

Re: Groups inside Mask-Groups displayed wrong(but render cor

Post by Greenlaw » Tue Oct 23, 2018 4:58 pm

FWIW, I normally have GPU Acceleration disabled too. As mentioned by Chucky, it often messes up when displaying masking. There are a few situations where enabling GPU acceleration will speed up Moho but, for me, having accurate (or mostly accurate) mask previews is far more important because I tend to use masking A LOT in my rigs.

IMO, Moho is usually fast enough with it disabled anyway.
D.R. Greenlaw
Artist/Partner - Little Green Dog | Little Green Dog Channel on Vimeo | Greenlaw's Demo Reel 2017
Lead Digital Animator, Dreamworks Animation

Image
DrNibbert
Posts: 46
Joined: Tue Jun 19, 2018 7:48 am

Re: Groups inside Mask-Groups displayed wrong(but render cor

Post by DrNibbert » Tue Oct 23, 2018 5:41 pm

Thanks for all your replies! You`re right, turning of GPU fixed the problem!

In another of my Rigs the Masking Group is displayed correctly WITH GPU and wrong when GPU is off :lol: Weird.
Guess i'll have to try case by case wich one works best.
Showreel 2018 https://vimeo.com/254290989 - Moho 12.5.1, macOS 10.10, Adobe CS6
User avatar
Greenlaw
Posts: 4360
Joined: Mon Jun 19, 2006 5:45 pm
Location: Los Angeles
Contact:

Re: Groups inside Mask-Groups displayed wrong(but render cor

Post by Greenlaw » Tue Oct 23, 2018 6:01 pm

Different graphics cards/chip sets and drivers might be the reason for the inconsistencies. The only way to know for sure is to try.

For me, I leave GPU acceleration off until I feel a project's interactivity is getting too slow to work with. Then I switch it on and, if it helps, I leave it on while I'm working in that project. If I see no difference in performance, I turn it off again.

A while back, I was told that the dev team was looking into improving Moho's openGL, so hopefully this means improvements for mask previews too. Just have to wait and see.
D.R. Greenlaw
Artist/Partner - Little Green Dog | Little Green Dog Channel on Vimeo | Greenlaw's Demo Reel 2017
Lead Digital Animator, Dreamworks Animation

Image
Post Reply