Unexplained movements

Discuss Moho bugs (or suspected bugs) with other users. To report bugs to Smith Micro, please visit support.smithmicro.com

Moderators: Fahim, Distinct Sun, Víctor Paredes, erey, Belgarath, slowtiger

Post Reply
User avatar
Diana Kennedy
Posts: 258
Joined: Fri Jan 30, 2009 11:21 pm
Location: France
Contact:

Unexplained movements

Post by Diana Kennedy » Sat Nov 16, 2019 10:17 pm

I had this problem since Anime Studio 11, and unfortunately it seems as if this issue is still present in Moho 13. unexpected and unwanted movements of shapes and groups of shapes.

Look at this file: https://drive.google.com/file/d/12qmgAi ... sp=sharing

There, the right eye (right from the viewer) makes a little jump between frames 99,100 and 101. Only a tiny one, bt it sucks.
This movements isn't triggered by any keyframe or other visible action. So WHY does it occur? And more importantly, how can it be fixed and avoided?
It is really an anoying bug that ruins otherwise cool animations.
User avatar
DK
Posts: 2438
Joined: Mon Aug 09, 2004 6:06 am
Location: Australia

Re: Unexplained movements

Post by DK » Sat Nov 16, 2019 11:43 pm

Hi Diana.
Yes...I get it too. It's weird. Usually movements like that are tied to a stray key frame that is interpolating between frames but i can't find the culprit here. Maybe Wes or one of the others will will have more luck.

EDIT oh...it's actually in both eyes if you look closely

Cheers
D.K
User avatar
DK
Posts: 2438
Joined: Mon Aug 09, 2004 6:06 am
Location: Australia

Re: Unexplained movements

Post by DK » Sun Nov 17, 2019 12:00 am

Hi Diane.
I think I have made some progress. If you cut the "Auge1" layer out of the group and paste it into a new document the movement seems to disappear. It seems it may be something to do with the master "Augen" layer? I also set the key frames on all vectors between those problematic frames to "Linear".
I have had strange things like this happen in Moho before....for instance...."Don't render this layer" has been set by a ghost on a couple occasions now and it took me ages to figure why something wasn't rendering. Go figure :roll:

Cheers
D.K
User avatar
synthsin75
Posts: 7156
Joined: Mon Jan 14, 2008 11:20 pm
Location: Oklahoma
Contact:

Re: Unexplained movements

Post by synthsin75 » Sun Nov 17, 2019 12:52 am

The problem is flexible binding. You can solve it by either setting Kopf01 to region binding, in the layer Bones tab, reducing the B2 bone strength to zero, or even deleting the layer transform keyframes from the Augen, Auge1, and Auge2 layers. This is happening because the layer movement keyframes are moving the layers inside these groups through the bone strength gradient. Much like this very old technique: http://www.lostmarble.com/forum/viewtopic.php?t=1443

Unless you really need multiple bones to smoothly warp layers, like image layers, I generally use region binding to get more predictable results.

Your eyes are also behind all the other layers too, as seen using the orbit view tool. That shouldn't be a factor, but looks unintentional.
User avatar
Diana Kennedy
Posts: 258
Joined: Fri Jan 30, 2009 11:21 pm
Location: France
Contact:

Re: Unexplained movements

Post by Diana Kennedy » Sun Nov 17, 2019 10:36 am

DK and Synthsin

Thank you so very very much for having this close look and giving me this advices. Now I have some hints how to fix and maybe avoid this problem.

UPDATE: Changing to Region binding solved the issue. Again thank you both.
Post Reply