Disable Space Bar Welding After Frame 0

Discuss ideas for new features with other users. To submit feature requests to Smith Micro, please visit support.smithmicro.com

Moderators: Fahim, Distinct Sun, Víctor Paredes, erey, Belgarath, slowtiger

Post Reply
User avatar
drumlug13
Posts: 489
Joined: Sun May 22, 2011 9:16 pm
Location: Beautiful St. Louis, MO

Disable Space Bar Welding After Frame 0

Post by drumlug13 » Mon Jul 13, 2015 8:00 pm

This occasionally sneaks up on me.

Using Space Bar to play/stop the cursor in the timeline is handy. Using Space Bar to weld point is also handy...

But when you're working down the timeline and you hit Space, thinking that it will Play, but it welds a couple of points together, and it doesn't make that welding sound, and you don't catch it right away, and the cursor doesn't play, and then you hit the space bar a few more times before you finally hit the play button with the mouse, and then you do like another 15 minutes of animation before you realize that you welded two points together 50 steps back, and you have to scrap a bunch of work... It kind of sucks.

Maybe either weld or play should be a combo short cut .... Control + Space, or Alt+Space
User avatar
synthsin75
Posts: 7103
Joined: Mon Jan 14, 2008 11:20 pm
Location: Oklahoma
Contact:

Re: Disable Space Bar Welding After Frame 0

Post by synthsin75 » Tue Jul 14, 2015 12:16 am

This doesn't seem to be a problem in AS11.
User avatar
drumlug13
Posts: 489
Joined: Sun May 22, 2011 9:16 pm
Location: Beautiful St. Louis, MO

Re: Disable Space Bar Welding After Frame 0

Post by drumlug13 » Tue Jul 14, 2015 1:21 am

It's happened to me at least a half dozen times in 11. And sometimes it doesn't make the click to signal a weld. It happened again today. It's sneaky.
User avatar
Víctor Paredes
Posts: 4863
Joined: Wed Jan 26, 2005 12:18 am
Location: Ireland/Chile
Contact:

Re: Disable Space Bar Welding After Frame 0

Post by Víctor Paredes » Tue Jul 14, 2015 2:53 am

It's not the exact solution you are looking for, but I recommend you to go to the Preferences > Tools and uncheck "Classic point editing keyboard shortcuts".
That basically changes this:
- Deselection will be made with Esc (instead of Enter)
- Weld and Create Shape confirmation will be made with Enter (instead of Space)
- Space will only play the animation

It takes a little time to get used to the new shortcuts, but the new cleaner and more intuitive way to work really deserves that time.
Víctor Paredes
Former Moho Product Manager
Animator in Cartoon Saloon
My Youtube Channel - My webinars
User avatar
drumlug13
Posts: 489
Joined: Sun May 22, 2011 9:16 pm
Location: Beautiful St. Louis, MO

Re: Disable Space Bar Welding After Frame 0

Post by drumlug13 » Tue Jul 14, 2015 3:00 am

That make a lot more sense. Thank you Sir.
Post Reply