PC version has lag when using "sticky key" feature

Discuss Moho bugs (or suspected bugs) with other users. To report bugs to Smith Micro, please visit support.smithmicro.com

Moderators: Fahim, Distinct Sun, Víctor Paredes, erey, Belgarath, slowtiger

Fuzatron
Posts: 67
Joined: Mon Dec 09, 2013 11:47 pm
Contact:

PC version has lag when using "sticky key" feature

Post by Fuzatron » Tue May 24, 2016 3:09 pm

I have Anime Studio installed on 3 machines - Surface Pro 3, Lenovo Desktop, and iMac. Both PC's running Win10... Sticky Keys allow you to temporarily switch to a tool like Width, Curvature, Transform, etc only while the shortcut key is being held down.

The Mac has no problem using sticky keys. ((NVidia GTX 675MX - 1024mb))

The PC Desktop - has very laggy tools when active under a sticky key. The only way around this is to toggle off all panels (~key). Although the Tools panel can be left on. ((NVidia 750 ti - 2048mb))

The Surface Pro 3 - Has the exact same behavior as the desktop when using an external keyboard. However, using the on-screen shortcut bar (Tablet Pro), there is no lag. Works as well as the Mac version. ((Intel gpu of some kind?))

This does not occur if you only have a few shapes in your scene. But import any of the AS11 sample characters (like the dragon), and you should see the lag. Makes no difference if you remove the bone layer from the characters.

If you haven't used the sticky key feature, this probably doesn't seem like a big deal at all. Once you get used to them, it's hard to go back though :?
User avatar
Víctor Paredes
Posts: 4981
Joined: Wed Jan 26, 2005 12:18 am
Location: Ireland/Chile
Contact:

Re: PC version has lag when using "sticky key" feature

Post by Víctor Paredes » Sun May 29, 2016 5:00 am

I AS 11.2 in Win 7 and 8 and the sticky keys are working. What version do you have?
Víctor Paredes
Former Moho Product Manager
Rigged animation supervisor in 'My father's dragon' - Lead Moho artist in 'Wolfwalkers'
Cartoon Saloon
My Youtube Channel - My webinars
Fuzatron
Posts: 67
Joined: Mon Dec 09, 2013 11:47 pm
Contact:

Re: PC version has lag when using "sticky key" feature

Post by Fuzatron » Sun May 29, 2016 4:17 pm

Hi Victor :)
I'm using 11.2.1 on both of my Win 10 PC's, and on an iMac. My sticky keys work, but require slower more deliberate motions than required when fully switching to the different tools. PC's only. The Mac is fine.

I re-installed, and tested while on 11.0, and had the same behavior, btw.

Here is a video to help explain what is happening on my PC's...
https://youtu.be/q6MhwZsPtKA

Thanks! :)

EDIT:
Also - Using "A" to add points, exhibits the same behavior. BUT, I have "A" and "T" mapped to a side mouse buttons, and do not see any lag when using them as sticky keys. And as stated in my first post, the behavior doesn't occur when using an on screen control panel for sticky keys on my Surface Pro 3... It must have to do with input from actual keyboards(?)
User avatar
Víctor Paredes
Posts: 4981
Joined: Wed Jan 26, 2005 12:18 am
Location: Ireland/Chile
Contact:

Re: PC version has lag when using "sticky key" feature

Post by Víctor Paredes » Tue May 31, 2016 3:22 pm

Fuzatron wrote:Hi Victor :)
I'm using 11.2.1 on both of my Win 10 PC's, and on an iMac. My sticky keys work, but require slower more deliberate motions than required when fully switching to the different tools. PC's only. The Mac is fine.

I re-installed, and tested while on 11.0, and had the same behavior, btw.

Here is a video to help explain what is happening on my PC's...
https://youtu.be/q6MhwZsPtKA

Thanks! :)

EDIT:
Also - Using "A" to add points, exhibits the same behavior. BUT, I have "A" and "T" mapped to a side mouse buttons, and do not see any lag when using them as sticky keys. And as stated in my first post, the behavior doesn't occur when using an on screen control panel for sticky keys on my Surface Pro 3... It must have to do with input from actual keyboards(?)
OK, now I can reproduce the issue, but only in one computer. I will create a report for it.
Thanks.
Víctor Paredes
Former Moho Product Manager
Rigged animation supervisor in 'My father's dragon' - Lead Moho artist in 'Wolfwalkers'
Cartoon Saloon
My Youtube Channel - My webinars
Fuzatron
Posts: 67
Joined: Mon Dec 09, 2013 11:47 pm
Contact:

Re: PC version has lag when using "sticky key" feature

Post by Fuzatron » Tue May 31, 2016 4:15 pm

Good to know it's reported!
Thanks, Victor :D
User avatar
synthsin75
Posts: 7280
Joined: Mon Jan 14, 2008 11:20 pm
Location: Oklahoma
Contact:

Re: PC version has lag when using "sticky key" feature

Post by synthsin75 » Tue May 31, 2016 7:24 pm

This is caused by the Repeat rate of your keyboard settings. This is where a key repeats if you hold it down. If you turn it all the way down to slow, the lag goes away. I'm not sure if AS can selectively ignore this setting or not.
Fuzatron
Posts: 67
Joined: Mon Dec 09, 2013 11:47 pm
Contact:

Re: PC version has lag when using "sticky key" feature

Post by Fuzatron » Tue May 31, 2016 8:09 pm

Thanks Synth! :)

It's still really strange that the problem goes away when the styles, layers, and timeline panels are all hidden.... And holding the backspace to delete text isn't much of an option now.... It's worth it to get my stick keys back though :D

For anyone else being bugged by this in windows 10, here is how you access the Repeat Rate setting...
https://www.reddit.com/r/Windows10/comm ... typing_on/
User avatar
synthsin75
Posts: 7280
Joined: Mon Jan 14, 2008 11:20 pm
Location: Oklahoma
Contact:

Re: PC version has lag when using "sticky key" feature

Post by synthsin75 » Tue May 31, 2016 8:45 pm

I forgot about the windows being hidden part. That probably means that this is fixable, since it would be those windows that are *listening* for repeating keys, and the tool window ignores them.
Fuzatron
Posts: 67
Joined: Mon Dec 09, 2013 11:47 pm
Contact:

Re: PC version has lag when using "sticky key" feature

Post by Fuzatron » Wed Jun 01, 2016 1:45 am

Stranger still :?

I think the layers may not have been as bad, possibly depending on the scene, but the timeline always did. Seems like the only way i could reliably get rid of the lag was to close all but the tools panel.

Just hope they get it fixed in the next update. Having the repeat rate low also makes things like nudging with the arrow keys in other apps, like photoshop, a little annoying..... My mac seems to have no repeat on keyboard characters, but it does on other keys like delete, arrows, and brackets. Wish i could get that behavior under windows 10.
User avatar
synthsin75
Posts: 7280
Joined: Mon Jan 14, 2008 11:20 pm
Location: Oklahoma
Contact:

Re: PC version has lag when using "sticky key" feature

Post by synthsin75 » Wed Jun 01, 2016 6:38 am

Since this is only seeming to show up on Windows, here's a temporary fix until the devs get a chance to address it.

https://dl.dropboxusercontent.com/u/536 ... %20fix.zip

This should completely eliminate the lag. It is a compiled AutoHotkey script, and will work for both 32-bit and 64-bit Windows. Unzip the program to anywhere you like and double-click it to allow AS to ignore the keyboard Repeat rate for keys A-Z & 0-9. All other programs (and any other keys in AS) will follow your Repeat rate settings.

If you want this program to run automatically whenever you start your computer, just put it in your Windows Startup folder.
Fuzatron
Posts: 67
Joined: Mon Dec 09, 2013 11:47 pm
Contact:

Re: PC version has lag when using "sticky key" feature

Post by Fuzatron » Wed Jun 01, 2016 10:03 am

WOW :shock:
This is working beautifully, Synth :D
Exactly as you described.

Thanks a BUNCH!!
Fuzatron
Posts: 67
Joined: Mon Dec 09, 2013 11:47 pm
Contact:

Re: PC version has lag when using "sticky key" feature

Post by Fuzatron » Wed Aug 10, 2016 2:01 am

Problem remains in Moho 12 :(
Maybe it'll be addressed in a point release.
User avatar
synthsin75
Posts: 7280
Joined: Mon Jan 14, 2008 11:20 pm
Location: Oklahoma
Contact:

Re: PC version has lag when using "sticky key" feature

Post by synthsin75 » Wed Aug 10, 2016 2:42 am

I've bumped the report for this. In the meantime, I'll see about updating the fix for Moho12.
Post Reply